Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Outline cannot open local OneNote folder

Martin Brandt Apr 20, 2017 11:15AM PDT


we are using Macs and Windows machines in our company and are heavily using OneNote on the Windows machines which are stored in SharePoint.
However I can access the SharePoint document library in Finder using WebDAV, but trying to load a notebook using WebDAV tells me, that my credentials are wrong although they are correct.

My second approach was to mount the library in Finder and the open a notebook "locally", but then Outline tells me that it "looks like you selected a folder, which is not a notebook."

Windows machine running OneNote 2013 and 2016 can open the notebooks without problems and buying Outline was my alternative for lacking support with OneNote for Mac with WebDAV or local notebooks.

Can I get some more information on what the error is or how to get our notebooks loaded in Outline?

Thanks in advance

Up 0 rated Down
Valya Apr 20, 2017 07:59PM PDT OUTLINE Helping Hand
Hi Martin,

Thanks for reaching out!

Did you purchase your Mac Outline through App Store?

At the moment we've already released Office 365 sync support in our Standalone version.
The same improvement will be released for App Store version in 3.19 update.

Could you please download the trial Standalone version and try to open your notebooks using "Open from Sharepoint Server" option?
Here is the link to the trial:
You will need to click "+" icon at the top of notebooks pane > Open from Sharepoint Server.

If you manage to open and sync your notebooks, I can give you the coupon code to switch to Standalone version.
Or you can wait a little bit to get the Sharepoint support in your App Store version.
Up 0 rated Down
Martin Brandt Apr 21, 2017 04:31AM PDT
Hi Alena,

thanks for your quick reply. Actually we are not using SharePoint Online. Sorry for that mistake. We are running SharePoint 2013 which throws an error when I try to load the notebook directly. This is being investigated by our IT department.

My point is that I mounted the SharePoint library using WebDAV and I try to open the notebook as if it was a local one. In this case I get the error message that the folder does not seem to be a notebook. I am using the AppStore version of Outline and tried the new version from your website but it shows the same result.

Thanks you very much for your help.

Best regards,
Up 0 rated Down
Valya Apr 21, 2017 04:52AM PDT OUTLINE Helping Hand

Well, I just thought it would be better to try to open this notebook with specially designed "Open from Sharepoint Server" option.
So that if this option gives you the same error, we will investigate the problem with Sharepoint Server connection.

And from the first glance it looks like you don't have a .toc file in your notebook folder.

Could you please open the folder and check if you have the "Open Notebook.onetoc2" file in root folder of your notebook?
If it's not there, you can copy it from any other notebook or section group > paste > try to open the notebook again.

Up 0 rated Down
Martin Brandt Apr 21, 2017 06:12AM PDT
Hi Alena,

the option to open the notebook with the specific "Open from SharePoint Server" functionality is also my preferred way, but it currently is not working due to configuration topics. We are going to investigate this internally as it is not working for me (Outline tells me, my credentials are, but they are not).

With your tip copying the file named "Open Notebook.onetoc2" into the notebook folder, Outline has successfully opened the notebook and I can read all notes. Great! Thanks for this.

Syncing changes to the WebDAV-notebook stored in SharePoint is not yet working, but I will check other questions in this portal as there were some topics regarding syncing issues with notebooks and in parallel we will double check the permissions in our SharePoint installation.

Thank you very much for your help.

Best regards,
Up 0 rated Down
Valya Apr 23, 2017 08:26PM PDT OUTLINE Helping Hand

Thank you for information!

If you don't manage to fix the log in to your Sharepoint Server from your side, please write to me.

We're releasing the new logs to record the account linking mechanism.
You'll be able to generate the logs in your Mac Outline and we will start investigating your case using them.
Up 0 rated Down
Martin Brandt Apr 24, 2017 01:22AM PDT
Hi Alena,

thanks for your reply. We actually managed it, so that I can log in to our SharePoint server.
However trying to open a notebook gives me an HTTP error 400, but Outline does not give me more information.

After copying the file into the folder, the notebook can be opened. However if a user running OneNote for Windows edits or syncs the notebook, the *.onetoc2 file is deleted again. Could this be a reason for the http error?

Kind regards,
Up 0 rated Down
Valya Apr 24, 2017 01:37AM PDT OUTLINE Helping Hand

Thank you for information!

I will ask ask the devs about this situation on tomorrows meeting.
We will need to test this scenario with .toc disappearing after notebook is used on PC.

If we don't find any straightforward solution, only logs will help.
If you're on Standalone Mac version at the moment (39.182.600), the update with the new logs will be available in a couple of days.

And I will get back tomorrow with more information from our dev team.
Up 0 rated Down
Martin Brandt Apr 24, 2017 02:24AM PDT

thanks for the update.
Actually I am on the AppStore version of Outline, but if it is possible, I am willing to switch to the Standalone version if it helps and if there is the possibility.

Kind regards,
Up 0 rated Down
Valya Apr 24, 2017 02:58AM PDT OUTLINE Helping Hand

I sent you an email with instruction.

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found